PT-2022-13219
CVE-2022-0501
·
Published
2022-02-05
·
Updated
2022-02-11
Description by
CVSS 3.1
8.6
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Name of the Vulnerable Software and Affected Versions
ptrofimov/beanstalk console versions prior to 1.7.12
Description
The issue is related to Cross-site Scripting (XSS) - Reflected, which occurs when an application includes user input in its responses without proper validation, allowing an attacker to inject malicious scripts. This can lead to unauthorized actions on behalf of the user. The estimated number of potentially affected devices worldwide is not specified. There is no information provided about real-world incidents where this issue was exploited.
Recommendations
For versions prior to 1.7.12, update to version 1.7.12 or later to resolve the issue. As a temporary workaround, consider restricting user input to minimize the risk of exploitation. Avoid using user-input data in responses until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾