PT-2022-13359
CVE-2022-0687
·
Published
2022-03-21
·
Updated
2022-03-30
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Amelia WordPress plugin versions prior to 1.0.47
Description
The issue allows logged-in users with the custom "Amelia Manager" role to potentially upload PHP backdoors onto the site. This is because the plugin stores image blobs into actual files whose extension is controlled by the user.
Recommendations
For versions prior to 1.0.47, update to version 1.0.47 or later to resolve the issue. As a temporary workaround, consider restricting the "Amelia Manager" role to trusted users only until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾