PT-2022-13407
CVE-2022-0747
·
Published
2022-03-21
·
Updated
2022-03-28
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Infographic Maker WordPress plugin versions prior to 4.3.8
Description
The issue concerns an unauthenticated SQL Injection. It occurs because the
post id parameter is not properly validated and escaped before being used in a SQL statement via the qcld upvote action AJAX action. This action is accessible to both unauthenticated and authenticated users.Recommendations
For versions prior to 4.3.8, update to version 4.3.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the
qcld upvote action AJAX action to minimize the risk of exploitation. Avoid using the post id parameter in the affected AJAX endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾