PT-2022-13430

CVE-2022-0776

·

Published

2022-03-01

·

Updated

2022-03-09

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions hakimel/reveal.js versions prior to 4.3.0
Description The issue is related to Cross-site Scripting (XSS) - DOM. Specifically, the onmessage event listener in /plugin/notes/speaker-view.html does not check the origin of postMessage before adding the content to the webpage. This allows any origin to postMessage on the browser window and feed attacker's input to parts, which can execute arbitrary javascript code on the victim's browser window hosting reveal.js.
Recommendations For versions prior to 4.3.0, update to version 4.3.0 or later to resolve the issue. As a temporary workaround, consider disabling the onmessage event listener in /plugin/notes/speaker-view.html until a patch is available. Restrict access to the /plugin/notes/speaker-view.html module to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-HHQJ-CFJX-VJ25
Found an issue in the description? Have something to add? Feel free to write us 👾