PT-2022-13595

CVE-2022-1020

·

Published

2022-04-18

·

Updated

2022-05-10

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions The Product Table for WooCommerce (wooproducttable) versions prior to 3.1.2
Description The issue concerns the lack of authorization and CSRF checks in the wpt admin update notice option AJAX action, which is accessible to both unauthenticated and authenticated users. Additionally, the callback parameter is not validated, allowing unauthenticated attackers to call arbitrary functions with either no or one user-controlled argument.
Recommendations For versions prior to 3.1.2, update to version 3.1.2 or later to resolve the issue. As a temporary workaround, consider disabling the wpt admin update notice option AJAX action until a patch is available. Restrict access to the wpt admin update notice option AJAX endpoint to minimize the risk of exploitation. Avoid using the callback parameter in the affected AJAX endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾