PT-2022-13737
CVE-2022-1237
·
Published
2022-04-06
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
radare2 versions prior to 5.6.8
Description
The issue is related to improper validation of array index, which can lead to a heap overflow and may be exploitable. This is a type of heap buffer overflow.
Recommendations
For versions prior to 5.6.8, update to version 5.6.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable function until a patch is available. Avoid using the vulnerable array index in the affected code until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾