PT-2022-1376
CVE-2022-39189
·
Published
2022-05-30
·
Updated
2026-10-19
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.18.17
Description
An issue in the x86 KVM subsystem of the Linux kernel allows unprivileged guest users to compromise the guest kernel due to mishandled TLB flush operations in certain KVM VCPU PREEMPTED situations. The vulnerability is related to incorrect handling of virtual processor state information. This could lead to local escalation of privilege with no additional execution privileges needed, and user interaction is not required for exploitation.
Recommendations
For Linux kernel versions prior to 5.18.17, update to version 5.18.17 or later to resolve the issue. As a temporary workaround, consider restricting access to the KVM subsystem to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾