PT-2022-14037

CVE-2022-1673

·

Published

2022-06-06

·

Updated

2022-06-15

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WooCommerce Green Wallet Gateway WordPress plugin versions prior to 1.0.2
Description The issue is related to a Reflected Cross-Site Scripting vulnerability. It occurs because the error envision query parameter is not properly escaped before being outputted to the page. This allows for potential malicious script injection.
Recommendations For versions prior to 1.0.2, update to version 1.0.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the page where the error envision query parameter is used until a patch is applied. Avoid using the error envision query parameter in affected pages until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾