PT-2022-14160

CVE-2022-1842

·

Published

2022-06-27

·

Updated

2022-07-06

Description by

CVSS 3.1
4.3
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions OpenBook Book Data WordPress plugin versions prior to 3.5.3
Description The issue is related to the lack of a CSRF check when updating settings, which could allow attackers to make a logged-in admin change them via a CSRF attack. This could lead to Stored Cross-Site Scripting due to the lack of sanitization and escaping.
Recommendations For OpenBook Book Data WordPress plugin versions prior to 3.5.3, update to version 3.5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the settings update functionality to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾