PT-2022-15275
CVE-2022-2215
·
Published
2022-08-01
·
Updated
2022-08-05
Description by
CVSS 3.1
4.8
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
GiveWP WordPress plugin versions prior to 2.21.3
Description
The issue concerns the improper sanitization and escaping of currency settings, potentially allowing high-privilege users, such as administrators, to perform Stored Cross-Site Scripting attacks. This is particularly relevant in setups where the unfiltered html capability is disallowed, such as in multisite configurations.
Recommendations
For versions prior to 2.21.3, update to version 2.21.3 or later to resolve the issue. As a temporary workaround, consider restricting the ability to modify currency settings to only trusted administrators and ensuring that all users with high privileges are aware of the potential for Stored Cross-Site Scripting attacks.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾