PT-2022-15612
CVE-2022-22664
·
Published
2022-03-14
·
Updated
2022-03-25
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Logic Pro versions prior to 10.7.3
GarageBand versions prior to 10.4.6
macOS Monterey versions prior to 12.3
Description
The issue is related to an out-of-bounds read that has been addressed with improved bounds checking. Opening a maliciously crafted file may lead to unexpected application termination or arbitrary code execution.
Recommendations
For Logic Pro versions prior to 10.7.3, update to version 10.7.3 or later.
For GarageBand versions prior to 10.4.6, update to version 10.4.6 or later.
For macOS Monterey versions prior to 12.3, update to version 12.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾