PT-2022-16078
CVE-2022-23562
·
Published
2022-02-04
·
Updated
2026-07-09
Description by
CVSS 3.1
7.6
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Name of the Vulnerable Software and Affected Versions
TensorFlow versions prior to 2.8.0
TensorFlow versions 2.7.1 and earlier
TensorFlow versions 2.6.3 and earlier
TensorFlow versions 2.5.3 and earlier
Description
The implementation of
Range suffers from integer overflows, which can trigger undefined behavior or extremely large allocations.Recommendations
For versions prior to 2.8.0, update to TensorFlow 2.8.0 or later.
For versions prior to 2.7.1, update to TensorFlow 2.7.1 or later.
For versions prior to 2.6.3, update to TensorFlow 2.6.3 or later.
For versions prior to 2.5.3, update to TensorFlow 2.5.3 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾