PT-2022-16080
CVE-2022-23564
·
Published
2022-02-04
·
Updated
2026-07-09
Description by
CVSS 4.0
7.1
HighMetricsAV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
TensorFlow versions prior to 2.5.3
TensorFlow versions prior to 2.6.3
TensorFlow versions prior to 2.7.1
TensorFlow versions prior to 2.8.0
Description
When decoding a resource handle tensor from protobuf, a TensorFlow process can encounter cases where a
CHECK assertion is invalidated based on user-controlled arguments. This allows attackers to cause denial of services in TensorFlow processes.Recommendations
For versions prior to 2.5.3, update to version 2.5.3 or later.
For versions prior to 2.6.3, update to version 2.6.3 or later.
For versions prior to 2.7.1, update to version 2.7.1 or later.
For versions prior to 2.8.0, update to version 2.8.0 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾