PT-2022-16092
CVE-2022-23575
·
Published
2022-02-04
·
Updated
2026-07-09
Description by
CVSS 4.0
7.1
HighMetricsAV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
TensorFlow versions prior to 2.8.0
TensorFlow versions 2.7.1 and earlier
TensorFlow versions 2.6.3 and earlier
TensorFlow versions 2.5.3 and earlier
Description
The implementation of
OpLevelCostEstimator::CalculateTensorSize is vulnerable to an integer overflow if an attacker can create an operation which would involve a tensor with large enough number of elements. This occurs because count and size can be large enough to cause count * size to overflow.Recommendations
For versions prior to 2.8.0, update to TensorFlow 2.8.0 or later.
For versions 2.7.1 and earlier, update to TensorFlow 2.7.1 or later.
For versions 2.6.3 and earlier, update to TensorFlow 2.6.3 or later.
For versions 2.5.3 and earlier, update to TensorFlow 2.5.3 or later.
As a temporary workaround, consider restricting the creation of operations involving large tensors until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾