PT-2022-16107

CVE-2022-23590

·

Published

2022-02-04

·

Updated

2026-07-09

Description by

CVSS 3.1
5.9
Medium
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions TensorFlow versions 2.7.0 through 2.7.0 and versions prior to 2.8.0
Description A GraphDef from a TensorFlow SavedModel can be maliciously altered to cause a TensorFlow process to crash due to encountering a StatusOr value that is an error and forcibly extracting the value from it.
Recommendations For versions prior to 2.8.0, update to TensorFlow 2.8.0. For versions prior to 2.7.1, update to TensorFlow 2.7.1. As a temporary workaround, consider restricting the use of GraphDef from TensorFlow SavedModel until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-PQRV-8R2F-7278
BIT-TENSORFLOW-2022-23590
OPENSUSE-SU-2024:12116-1
PYSEC-2022-154
PYSEC-2022-99
PYSEC-2026-3225
Found an issue in the description? Have something to add? Feel free to write us 👾