PT-2022-16139

CVE-2022-23625

·

Published

2022-03-11

·

Updated

2022-03-18

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Wire-ios versions prior to 3.95
Description The issue is related to malformed resource identifiers that can cause the iOS Wire Client to crash repeatedly on launch. These identifiers can be sent between Wire users, leading to undesirable behavior. The root cause is in the code responsible for removing sensible tokens before logging, which may fail and cause a crash. Although the greater Wire system remains functional, users are advised to upgrade as soon as possible.
Recommendations For versions prior to 3.95, upgrade to version 3.95 or later as soon as possible to resolve the issue. As a temporary workaround, consider avoiding the use of malformed resource identifiers to minimize the risk of application crashes.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-3XVH-X964-572H
GHSA-RQ36-8QFP-79MC
Found an issue in the description? Have something to add? Feel free to write us 👾