PT-2022-16483
CVE-2022-24129
·
Published
2022-02-04
·
Updated
2022-02-09
Description by
CVSS 3.1
8.2
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
Name of the Vulnerable Software and Affected Versions
Shibboleth Identity Provider OIDC OP plugin versions prior to 3.0.4
Description
The issue allows server-side request forgery (SSRF) due to insufficient restriction of the
request uri parameter. This enables attackers to interact with arbitrary third-party HTTP services.Recommendations
For versions prior to 3.0.4, update to version 3.0.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
request uri parameter to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾