PT-2022-16578
CVE-2022-24278
·
Published
2022-06-10
·
Updated
2022-06-17
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
convert-svg-core versions prior to 0.6.4
Description
The issue arises from improper sanitization of SVG tags, allowing for Directory Traversal attacks. This can be exploited by using a specially crafted SVG file.
Recommendations
For versions prior to 0.6.4, update to version 0.6.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of convert-svg-core until a patch is applied. Avoid using convert-svg-core with untrusted SVG files until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾