PT-2022-16668
CVE-2022-24393
·
Published
2022-05-17
·
Updated
2022-05-26
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Fidelis Network and Deception versions prior to 9.4.5
Description
The issue allows authenticated command injection through the web interface using the
check vertica upgrade value for the cpIp parameter. This could enable a specially crafted HTTP request to execute system commands on the CommandPost and return results in an HTTP response via an authenticated session.Recommendations
For versions prior to 9.4.5, update to version 9.4.5 or later to address this issue. As a temporary workaround, consider restricting access to the web interface or limiting the use of the
cpIp parameter until a patch is applied. Found an issue in the description? Have something to add? Feel free to write us 👾