PT-2022-16830

CVE-2022-24722

·

Published

2022-03-02

·

Updated

2022-03-10

Description by

CVSS 3.1
8.1
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions ViewComponent versions prior to 2.31.2 ViewComponent versions prior to 2.49.1
Description The issue is related to a cross-site scripting vulnerability in the view component gem, specifically affecting translations. Data received via user input and passed as an interpolation argument to the translate method is not properly sanitized before display.
Recommendations For versions prior to 2.31.2, update to version 2.31.2 or later to fully mitigate the vulnerability. For versions prior to 2.49.1, update to version 2.49.1 or later to fully mitigate the vulnerability. As a temporary workaround, consider avoiding passing user input to the translate function, or sanitize the inputs before passing them.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-CM9W-C4RJ-R2CF
Found an issue in the description? Have something to add? Feel free to write us 👾