PT-2022-16861
CVE-2022-24759
·
Published
2022-03-17
·
Updated
2022-03-23
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Name of the Vulnerable Software and Affected Versions
@chainsafe/libp2p-noise versions prior to 4.1.2
@chainsafe/libp2p-noise versions prior to 5.0.3
Description
The issue is related to the incorrect validation of signatures during the handshake process in the noise protocol implementation. This may allow a man-in-the-middle to pose as other peers and get those peers banned.
Recommendations
For versions prior to 4.1.2, upgrade to version 4.1.2 to receive a patch.
For versions prior to 5.0.3, upgrade to version 5.0.3 to receive a patch.
As a temporary workaround, consider restricting access to the handshake process until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾