PT-2022-17227

CVE-2022-25345

·

Published

2022-06-17

·

Updated

2022-06-28

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions @discordjs/opus versions prior to 0.8.0
Description The issue is related to a Denial of Service (DoS) condition that occurs when trying to encode using an encoder with zero channels or a non-initialized buffer, leading to a hard crash. This is due to improperly handled errors that cause the application to crash instead of returning the error to the user.
Recommendations For versions prior to 0.8.0, update to version 0.8.0 or later to resolve the issue, as this version correctly returns errors to the user instead of causing a hard crash.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-RVGF-69J7-XH78
SNYK-JS-DISCORDJSOPUS-2403100
Found an issue in the description? Have something to add? Feel free to write us 👾