PT-2022-19400
CVE-2022-29077
·
Published
2022-04-25
·
Updated
2022-05-04
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
rippled versions prior to 1.8.5
Description
A heap-based buffer overflow exists, allowing attackers to cause a crash or execute commands remotely on a rippled node. This may lead to XRPL mainnet DoS or compromise, exposing all digital assets on the XRPL to a security threat.
Recommendations
For versions prior to 1.8.5, update to version 1.8.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the rippled node to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾