PT-2022-19469
CVE-2022-29216
·
Published
2022-05-20
·
Updated
2026-07-09
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
TensorFlow versions prior to 2.9.0
TensorFlow versions prior to 2.8.1
TensorFlow versions prior to 2.7.2
TensorFlow versions prior to 2.6.4
Description
TensorFlow is an open source platform for machine learning. The
saved model cli tool is vulnerable to a code injection, which can be used to open a reverse shell. This code path was maintained for compatibility reasons as the maintainers had several test cases where numpy expressions were used as arguments. However, given that the tool is always run manually, the impact of this is still not severe. The maintainers have now removed the safe=False argument, so all parsing is done without calling eval.Recommendations
For versions prior to 2.9.0, update to version 2.9.0 or later.
For versions prior to 2.8.1, update to version 2.8.1 or later.
For versions prior to 2.7.2, update to version 2.7.2 or later.
For versions prior to 2.6.4, update to version 2.6.4 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾