PT-2022-19686
CVE-2022-29536
·
Published
2022-04-20
·
Updated
2026-10-01
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
GNOME Epiphany versions prior to 41.4
GNOME Epiphany versions 42.x prior to 42.2
Description
The issue occurs because the number of bytes for a UTF-8 ellipsis character is not properly considered, allowing an HTML document to trigger a client buffer overflow via a long page title. This happens in the
ephy string shorten function within the UI process.Recommendations
For GNOME Epiphany versions prior to 41.4, update to version 41.4 or later.
For GNOME Epiphany versions 42.x prior to 42.2, update to version 42.2 or later.
As a temporary workaround, consider restricting the use of long page titles until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾