PT-2022-2043
CVE-2022-0547
·
Published
2022-03-18
·
Updated
2025-10-20
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
OpenVPN versions 2.1 through 2.4.12
OpenVPN versions 2.5.6 and earlier
Description
The issue is related to a flaw in the authentication procedure, which can be exploited by a remote attacker to bypass authentication and gain access to confidential information. This occurs when multiple external authentication plug-ins use deferred authentication replies, allowing an external user to be granted access with only partially correct credentials.
Recommendations
For OpenVPN versions 2.1 through 2.4.12, update to a version later than 2.4.12 to resolve the issue.
For OpenVPN versions 2.5.6 and earlier, update to a version later than 2.5.6 to resolve the issue.
As a temporary workaround, consider disabling the use of multiple external authentication plug-ins that make use of deferred authentication replies until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾