PT-2022-20530

CVE-2022-31103

·

Published

2022-06-23

·

Updated

2022-07-06

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions lettersanitizer versions prior to 1.0.2
Description The issue is a denial of service problem that occurs when processing a CSS at-rule @keyframes. This package is depended on by react-letter, therefore everyone using react-letter is also at risk.
Recommendations For versions prior to 1.0.2, update to version 1.0.2 to resolve the issue. As a temporary workaround, consider avoiding the use of the @keyframes CSS at-rule until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-7R3R-GQ8P-V9JJ
Found an issue in the description? Have something to add? Feel free to write us 👾