PT-2022-20539

CVE-2022-31115

·

Published

2022-06-30

·

Updated

2022-07-25

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions opensearch-ruby versions prior to 2.0.1
Description The issue is related to the use of the ruby YAML.load function instead of YAML.safe load in opensearch-ruby, which can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability.
Recommendations For versions prior to 2.0.1, upgrade to version 2.0.1 or later to resolve the issue. As a temporary workaround, consider avoiding the use of YAML responses until the issue is resolved. Restrict access to opensearch servers to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-977C-63XQ-CGW3
Found an issue in the description? Have something to add? Feel free to write us 👾