PT-2022-20556

CVE-2022-31136

·

Published

2022-07-07

·

Updated

2022-07-15

Description by

CVSS 3.1
6.3
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions Bookwyrm versions prior to 0.4.1
Description The issue concerns an open source social reading and reviewing program where versions prior to 0.4.1 did not properly sanitize HTML being rendered to users. Unprivileged users can inject scripts into user profiles, book descriptions, and statuses, potentially leading to cross-site scripting attacks on users viewing these fields.
Recommendations For versions prior to 0.4.1, upgrade to version 0.4.1 to resolve the issue. As a temporary workaround, consider restricting access to user profiles, book descriptions, and statuses until the upgrade is applied. Avoid using the affected fields in the program until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2CFH-V7RF-PXFP
Found an issue in the description? Have something to add? Feel free to write us 👾