PT-2022-20714

CVE-2022-31358

·

Published

2022-12-14

·

Updated

2024-10-29

Description by

CVSS 3.1
9.0
Critical
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Proxmox Virtual Environment versions prior to 7.2-3
Description A reflected cross-site scripting (XSS) issue allows remote attackers to execute arbitrary web scripts or HTML via non-existent endpoints under the path "/api2/html/". This enables attackers to potentially manipulate web content.
Recommendations For versions prior to 7.2-3, update to version 7.2-3 or later to resolve the issue. As a temporary workaround, consider restricting access to non-existent endpoints under the "/api2/html/" path to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾