PT-2022-21220

CVE-2022-32308

·

Published

2022-06-29

·

Updated

2023-01-31

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions uBlock Origin versions prior to 1.41.1
Description A Cross Site Scripting (XSS) issue allows remote attackers to run arbitrary code via a spoofed MessageSender.url to the browser renderer process. This enables attackers to execute malicious scripts, potentially leading to unauthorized actions on the affected system.
Recommendations For versions prior to 1.41.1, update to version 1.41.1 or later to resolve the issue. As a temporary workaround, consider restricting access to potentially vulnerable websites or disabling the uBlock Origin extension until the update is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2023-1156
DLA-3062-1
Found an issue in the description? Have something to add? Feel free to write us 👾