PT-2022-23008

CVE-2022-35900

·

Published

2022-07-15

·

Updated

2022-07-21

Description by

CVSS 3.1
3.3
Low
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions Bentley MicroStation versions prior to 10.17.0.x Bentley View versions prior to 10.17.0.x
Description An issue was discovered in the parsing of JP2 files, which can force an out-of-bounds read when opening a JP2 file containing crafted data using an affected version of MicroStation or a MicroStation-based application. This could enable an attacker to read information in the context of the current process.
Recommendations For Bentley MicroStation versions prior to 10.17.0.x, update to version 10.17.0.x or later to resolve the issue. For Bentley View versions prior to 10.17.0.x, update to version 10.17.0.x or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾