PT-2022-23013

CVE-2022-35905

·

Published

2022-07-15

·

Updated

2022-07-21

Description by

CVSS 3.1
3.3
Low
MetricsAC:L/AV:L/A:N/C:L/I:N/PR:N/S:U/UI:R
Name of the Vulnerable Software and Affected Versions Bentley MicroStation versions prior to 10.17.0.x Bentley View versions prior to 10.17.0.x
Description An issue was discovered in the parsing of FBX files, which can force an out-of-bounds read when an affected version of MicroStation or MicroStation-based application is used to open a crafted FBX file. This could enable an attacker to read information in the context of the current process.
Recommendations For Bentley MicroStation versions prior to 10.17.0.x, update to version 10.17.0.x or later to resolve the issue. For Bentley View versions prior to 10.17.0.x, update to version 10.17.0.x or later to resolve the issue. As a temporary workaround, consider avoiding the use of FBX files with affected versions of MicroStation or MicroStation-based applications until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾