PT-2022-23212
CVE-2022-36125
·
Published
2022-08-09
·
Updated
2026-03-06
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Apache Avro Rust SDK versions prior to 0.14.0
Description
It is possible to crash an application by providing corrupted data to be read. This issue affects Rust applications using the Apache Avro Rust SDK.
Recommendations
For versions prior to 0.14.0, update to apache-avro version 0.14.0 to address this issue.
Found an issue in the description? Have something to add? Feel free to write us 👾