PT-2022-25063
CVE-2022-39871
·
Published
2022-10-07
·
Updated
2022-10-11
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
SmartThings versions prior to 1.7.89.0
Description
The issue is related to an improper access control vulnerability in the cloudNotificationManager.java file. This vulnerability allows attackers to access sensitive information via implicit broadcasts.
Recommendations
For versions prior to 1.7.89.0, update to version 1.7.89.0 or later to resolve the issue. As a temporary workaround, consider restricting access to sensitive information until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾