PT-2022-2726
CVE-2022-1769
·
Published
2022-05-17
·
Updated
2024-06-15
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2.4974
Description
The issue is related to a buffer over-read in the Vim text editor, specifically in the
get one sourceline() function, which can allow a remote attacker to access confidential information by exploiting the vulnerability.Recommendations
For versions prior to 8.2.4974, update to version 8.2.4974 or later to resolve the issue.
As a temporary workaround, consider restricting access to sensitive information until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾