PT-2022-2728
CVE-2022-1733
·
Published
2022-05-08
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 8.2.4968
Description
The issue is related to a heap-based buffer overflow in the skip string() function of the Vim text editor. This can be exploited by an attacker to cause a denial of service or execute arbitrary code by loading a specially crafted file. The vulnerability can be triggered remotely by tricking the victim into opening a malicious file, leading to a heap buffer overflow and potential code execution on the target system.
Recommendations
For versions prior to 8.2.4968, update to version 8.2.4968 or later to resolve the issue. As a temporary workaround, consider disabling the
skip string() function until a patch is available. Restrict access to untrusted files to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾