PT-2022-2733
CVE-2022-1785
·
Published
2022-05-16
·
Updated
2025-03-30
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 8.2.4977
Description
The issue is related to an out-of-bounds write in the vim regsub both() function of the Vim text editor, which can be exploited by an attacker to execute arbitrary code or cause a denial of service using a specially crafted file. The vulnerability is associated with a buffer overflow error when processing untrusted input data.
Recommendations
For versions prior to 8.2.4977, update to version 8.2.4977 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vim regsub both() function until a patch is available. Avoid opening specially crafted files that may trigger the vulnerability.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾