PT-2022-2735

CVE-2022-1771

·

Published

2022-05-16

·

Updated

2024-06-15

Description by

CVSS 3.1
5.5
Medium
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions vim versions prior to 8.2.4975
Description The issue is caused by uncontrolled recursion in the Vim text editor. Exploitation of this issue may allow an attacker to cause a denial of service. It is also related to a boundary error when processing certain input, which can lead to a stack-based buffer overflow, resulting in a denial of service attack.
Recommendations For versions prior to 8.2.4975, update to version 8.2.4975 or later to resolve the issue. At the moment, there is no information about additional mitigation measures for this vulnerability.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2022-1948
ALT-PU-2022-1958
ALT-PU-2022-1977
ALT-PU-2022-1987
AZL-9789
OESA-2022-1717
OPENSUSE-SU-2022_2102-1
OPENSUSE-SU-2024:12337-1
SUSE-SU-2022:2102-1
SUSE-SU-2022:4619-1
USN-6557-1
Found an issue in the description? Have something to add? Feel free to write us 👾