PT-2022-27412
CVE-2022-45132
·
Published
2022-11-18
·
Updated
2022-11-23
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linaro Automated Validation Architecture (LAVA) versions prior to 2022.11.1
Description
The issue allows remote code execution through user-submitted Jinja2 templates. Specifically, the REST API endpoint for validating device configuration files in lava-server loads input as a Jinja2 template, which can be exploited to trigger remote code execution in the LAVA server.
Recommendations
For versions prior to 2022.11.1, update to version 2022.11.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the REST API endpoint responsible for validating device configuration files in lava-server until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾