PT-2022-2752
CVE-2022-1381
·
Published
2022-04-13
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2.4763
Description
The issue is related to a global heap buffer overflow in the skip range function of the Vim text editor. This can be exploited to crash the software, bypass protection mechanisms, modify memory, and potentially allow for remote execution of arbitrary code. The vulnerability can be triggered by a specially crafted file, which, when opened by the victim, can lead to unauthorized writing and execution of arbitrary code in the target system.
Recommendations
For versions prior to 8.2.4763, update to version 8.2.4763 or later to resolve the issue.
As a temporary workaround, consider avoiding the use of the skip range function in the Ex mode until a patch is available.
Restrict access to untrusted input files to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾