PT-2022-28796

Published

2022-02-27

·

Updated

2022-02-27

Description by

Score
N/A
Not available

No severity ratings or metrics are available. When they are, we'll update the corresponding info on the page.

Name of the Vulnerable Software and Affected Versions Linux Kernel versions v5.16.3 through v5.16.9
Description The issue is related to the eeprom module, specifically the ee1004 component, where I2C reads are not properly limited to I2C SMBUS BLOCK MAX. This could potentially lead to security vulnerabilities, although the actual impact and attack plausibility have not yet been proven.
Recommendations For Linux Kernel versions v5.16.3 through v5.16.9, update to version v5.16.10 or later to resolve the issue.
Vendors
Affected products
Related identifiers
GSD-2022-1000522
Found an issue in the description? Have something to add? Feel free to write us 👾