PT-2022-3214
CVE-2022-1160
·
Published
2022-03-28
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2.4647
Description
The issue is related to a heap buffer overflow in the
get one sourceline() function of the Vim text editor. This can be exploited by opening a specially crafted file, potentially allowing an attacker to cause a denial of service or execute arbitrary code.Recommendations
For versions prior to 8.2.4647, update to version 8.2.4647 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
get one sourceline() function until a patch is applied.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾