PT-2022-3314
CVE-2022-34481
·
Published
2022-06-28
·
Updated
2025-04-03
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Firefox versions prior to 102
Firefox ESR versions prior to 91.11
Thunderbird versions prior to 102
Thunderbird versions prior to 91.11
Description
The issue is related to an integer overflow in the
nsTArray Impl::ReplaceElementsAt() function. This could allow a remote attacker to execute arbitrary code by forcing the victim to visit a specially crafted website, triggering the integer overflow. The vulnerability affects the Mozilla Thunderbird email client and the Mozilla Firefox browser.Recommendations
For Firefox versions prior to 102, update to version 102 or later.
For Firefox ESR versions prior to 91.11, update to version 91.11 or later.
For Thunderbird versions prior to 102, update to version 102 or later.
For Thunderbird versions prior to 91.11, update to version 91.11 or later.
As a temporary workaround, consider restricting access to potentially vulnerable websites to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾