PT-2022-3318
CVE-2022-2284
·
Published
2022-07-02
·
Updated
2026-10-23
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
vim versions prior to 9.0
Description
The issue is related to a heap-based buffer overflow in the utfc ptr2len() function of the Vim text editor. This can allow an attacker to impact the confidentiality, integrity, and availability of protected information.
Recommendations
For versions prior to 9.0, update to version 9.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the utfc ptr2len() function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾