PT-2022-3447
CVE-2022-1942
·
Published
2022-05-31
·
Updated
2025-03-30
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 8.2
Description
The issue is related to a heap-based buffer overflow in the Vim text editor, specifically in the
vim regsub both() function, which can be exploited by a remote attacker to execute arbitrary code. This overflow occurs in the dynamic memory, potentially allowing for code execution. The estimated number of potentially affected devices worldwide is not specified.Recommendations
For versions prior to 8.2, update to version 8.2 or later to resolve the issue.
As a temporary workaround, consider disabling the
vim regsub both() function until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾