PT-2022-3601
CVE-2022-29187
·
Published
2022-07-12
·
Updated
2026-09-30
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Git versions prior to 2.37.1
Git versions prior to 2.36.2
Git versions prior to 2.35.4
Git versions prior to 2.34.4
Git versions prior to 2.33.4
Git versions prior to 2.32.3
Git versions prior to 2.31.4
Git versions prior to 2.30.5
Description
The issue is related to a distributed system management vulnerability in Git, which can be exploited by creating a folder named "C:.git". This could allow an attacker to run arbitrary commands. To minimize the risk, it is recommended to avoid running Git as root or with administrator privileges, especially when navigating shared directories where an attacker could create a Git repository.
Recommendations
For Git versions prior to 2.37.1, update to version 2.37.1 or later.
For Git versions prior to 2.36.2, update to version 2.36.2 or later.
For Git versions prior to 2.35.4, update to version 2.35.4 or later.
For Git versions prior to 2.34.4, update to version 2.34.4 or later.
For Git versions prior to 2.33.4, update to version 2.33.4 or later.
For Git versions prior to 2.32.3, update to version 2.32.3 or later.
For Git versions prior to 2.31.4, update to version 2.31.4 or later.
For Git versions prior to 2.30.5, update to version 2.30.5 or later.
As a temporary workaround, consider avoiding running Git as root or with administrator privileges to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾