PT-2022-3730
CVE-2022-21455
·
Published
2022-07-19
·
Updated
2024-08-30
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
MySQL Server versions 8.0.28 and prior
Description
The issue is related to insufficient input validation in the Server: PAM Auth Plugin component of MySQL Server, allowing a high-privileged attacker with network access via multiple protocols to compromise the server. Successful attacks can result in unauthorized creation, deletion, or modification access to critical data or all MySQL Server accessible data. The vulnerability can also cause a hang or frequently repeatable crash of MySQL Server.
Recommendations
For versions 8.0.28 and prior, update to a version later than 8.0.28 to resolve the issue.
At the moment, there is no information about a newer version that contains a fix for this vulnerability.
Found an issue in the description? Have something to add? Feel free to write us 👾