PT-2022-3941
CVE-2022-26307
·
Published
2022-05-20
·
Updated
2024-06-15
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
LibreOffice versions prior to 7.2.7
LibreOffice versions prior to 7.3.3
Description
A flaw in LibreOffice existed where the master key used for encrypting stored passwords was poorly encoded, resulting in weakened entropy from 128 to 43 bits. This made the stored passwords vulnerable to a brute force attack if an attacker had access to the user's stored configuration. The issue is related to insufficiently strong encryption of data, which could allow a remote attacker to impact the confidentiality, integrity, and availability of protected information.
Recommendations
For versions prior to 7.2.7, update to version 7.2.7 or later.
For versions prior to 7.3.3, update to version 7.3.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾