PT-2022-4189
CVE-2022-0757
·
Published
2022-03-17
·
Updated
2022-06-02
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Rapid7 Nexpose versions 6.6.93 and earlier
Description
The issue is related to insufficient protection of the SQL query structure, allowing a logged-in, authenticated attacker to manipulate the
ANY and OR operators in the SearchCriteria and inject SQL code. This can be exploited by manipulating the /data/asset/filterAssets endpoint.Recommendations
For Rapid7 Nexpose versions 6.6.93 and earlier, update to version 6.6.129 or later to resolve the issue. As a temporary workaround, consider restricting access to the
/data/asset/filterAssets endpoint until a patch is applied. Additionally, limiting the use of the ANY and OR operators in the SearchCriteria can help minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾